System/machines/levitation/home.nix

123 lines
2.9 KiB
Nix

{ config, lib, pkgs, inputs, ... }: {
nathan = {
services = { email = { enable = true; }; };
config = { isDesktop = true; };
programs = {
util = {
wine = true;
git = {
gpgSign = false;
sshSign = true;
};
};
games = { launcher = true; };
media.nicotineService = true;
};
};
home.packages = with pkgs; [ gammastep fido2luks ];
# Hyprland outputs
wayland.windowManager.hyprland.extraConfig = ''
# monitor=DP-3,preferred,auto,1.4,bitdepth,10
# disable 10 bit output for now as this breaks screenshots
misc {
vrr = 1
no_direct_scanout = false
}
monitor=DP-3,preferred,auto,1.4
input {
sensitivity = -0.8
# accel_profile = flat
}
master {
mfact = 0.68
}
'';
################################################################################
# Background
xdg.configFile."hypr/hyprpaper.conf" = {
text = ''
preload = /home/nathan/Pictures/Backgrounds/IMG_20190518_195619.jpg
wallpaper = DP-3,/home/nathan/Pictures/Backgrounds/IMG_20190518_195619.jpg
'';
};
# Gammastep
services.gammastep = {
enable = true;
latitude = 38.02972;
longitude = -84.49472;
tray = true;
temperature = {
day = 6300;
night = 4300;
};
settings = { general = { fade = 1; }; };
};
# System specific autoruns
systemd.user.services = {
# Start up solaar in tray icon mode
solaar = {
Unit = {
Description = "Solarr";
After = [ "graphical-session.target" ];
};
Service = {
Type = "simple";
ExecStart = ''
${pkgs.solaar}/bin/solaar -w hide
'';
};
Install = { WantedBy = [ "graphical-session.target" ]; };
};
# Hyprpaper
# Run as service so we can easily restart it after kvm switching
hyprpaper = {
Unit = {
Description = "Hyprpaper";
After = [ "graphical-session.target" ];
};
Service = {
Type = "simple";
ExecStart = ''
${inputs.hyprpaper.packages.${pkgs.system}.hyprpaper}/bin/hyprpaper
'';
};
Install = { WantedBy = [ "graphical-session.target" ]; };
};
# Startup noisetorch on our USB mic
noisetorch-startup = {
Unit = {
Description = "noisetorch";
After = [ "graphical-session.target" ];
};
Service = {
Type = "oneshot";
ExecStartPre = "/run/current-system/sw/bin/sleep 5";
ExecStart = ''
/run/wrappers/bin/noisetorch -i alsa_input.usb-18072020_JLAB_TALK_GO_MICROPHONE-00.analog-stereo
'';
};
# Install = { WantedBy = [ "graphical-session.target" ]; };
};
};
# Looking glass
xdg.configFile."looking-glass/client.ini" = {
text = ''
[input]
rawMouse=yes
[audio]
periodSize=512
bufferLatency=7
micDefault=allow
[egl]
scale = 1
'';
};
}