System/machines/productivity-vm/home.nix

40 lines
711 B
Nix

{ config, lib, pkgs, ... }:
{
nathan = {
config = { isDesktop = true; };
programs = {
media.enable = false;
util = {
wine = true;
git = {
gpgSign = false;
sshSign = true;
};
};
};
};
home.packages = with pkgs; [ gammastep ];
# Hyprland outputs + tweaks
wayland.windowManager.hyprland.extraConfig = ''
monitor=,2560x1440,auto,1.5
input {
# sensitivity = -0.8
# accel_profile = flat
}
# exec-once=hyprpaper
'';
# System specific autoruns
systemd.user.services = { };
# Mako output configuration
services.mako = {
# Lock mako notifs to main display
output = "Virtual-1";
};
}