System/machines/wsl/configuration.nix

29 lines
539 B
Nix

{ config, lib, pkgs, ... }:
{
# Setup system configuration
nathan = {
services = {
ssh = false;
tailscale.enable = false;
};
config = {
installUser = false;
nix.autoUpdate = false;
harden = false;
fonts = true;
};
};
# Configure networking
networking = { domain = "mccarty.io"; };
# Setup WSL
wsl = {
enable = true;
defaultUser = "nathan";
# nativeSystemd = true;
};
security.sudo.enable = true;
environment.systemPackages = with pkgs; [ syncthing ];
}