System/home-manager/modules/programs/desktop.nix
2025-01-28 21:44:17 -05:00

56 lines
1,013 B
Nix

{
config,
lib,
pkgs,
inputs',
...
}: {
home.packages = with pkgs; [
# Communications
webcord-vencord
protonmail-desktop
signal-desktop
caprine
# Utility
protonvpn-gui
# Browser
firefoxpwa
ungoogled-chromium
];
programs.firefox = {
enable = true;
nativeMessagingHosts = with pkgs; [
kdePackages.plasma-browser-integration
];
};
services.syncthing = {
enable = true;
tray = {
enable = true;
};
};
# Setup foot as our terminal emulator
programs.foot = {
enable = true;
server.enable = true;
settings = {
main = {
font = "JetBrainsMono NF:size=8";
dpi-aware = "yes";
};
};
};
# Refresh the KDE applications cache, this really should be in upstream home
# manager, but its not for some reason
home.activation = {
kdeApplicationCache = lib.hm.dag.entryAfter ["installPackages"] ''
run rm ~/.cache/ksycoca6_* -rf
run kbuildsycoca6
'';
};
}